[KB3544] Reparador de instalaciones de ESET

NOTA:

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Problema

Solución

¿Qué es ESET Installation Fixer?

ESET Installation Fixer (InstaFix, install fix) es una herramienta de soporte técnico para los productos ESET. ESET Installation Fixer está diseñado para solucionar varios problemas que pueden ocurrir con los servicios durante la instalación del software de ESET.

Sólo para productos domésticos, de punto final y de servidor de ESET

La herramienta ESET Installation Fixer sólo se puede utilizar para los productos ESET Home, Endpoint y Server. No se puede utilizar para agentes de gestión.

Antes de utilizar ESET Installation Fixer
  • Ejecute el programa sólo cuando se lo indique el soporte técnico de ESET.
  • El programa debe ejecutarse desde una cuenta administrativa. Los comandos de Installation Fixer deben ejecutarse mediante un símbolo del sistema con privilegios elevados de administrador completo.
  • ESET Installation Fixer no funcionará en modo seguro.
  • Si trabaja en un sistema operativo de 64 bits, debe utilizar una versión de 64 bits de ESET Installation Fixer.
  • ESET Installation Fixer está diseñado para su uso en Windows XP SP3 y versiones posteriores de Windows.

Esta versión actual es compatible con las siguientes correcciones:


¿Cómo se utiliza ESET Installation Fixer?

  1. Haga clic en el enlace correspondiente para descargar el ESET Installation Fixer para su sistema operativo (Haga clic para ver los pasos necesarios para determinar si su sistema operativo es de 32 o 64 bits):
  1. Una vez finalizada la descarga de la herramienta, ejecute ESET Installation Fixer desde un símbolo del sistema administrativo utilizando uno de los comandos que se detallan a continuación. Todos los comandos deben agregarse después del directorio donde se encuentra el Installation Fixer, por ejemplo:

    C:\Usuarios\Propietario\Escritorio\InstFix_nt64.exe -fix MRL

    Usuarios con la versión de 32 bits

    Los usuarios con la versión de 32 bits de Installation Fixer escribirán "InstFix_nt32.exe" en lugar de "InstFix_nt64.exe"


Restos del Registro MSI

Problema

Un intento de actualizar un producto ESET a la última versión falla. El registro de instalación informa del error "Error 2753: El archivo 'shellExt.dll' no está marcado para la instalación"

Causa
  • El proceso de actualización se interrumpe por una nueva instalación de un producto anterior que ya se actualizó en el pasado. Esto sucede justo después de que la sección RunEngine responsable de eliminar el producto que se está actualizando finalice correctamente.
  • Se sospecha que el servicio de gestión de aplicaciones de directivas de grupo (AppMgmt) está ejecutando la instalación del software que falta. El motivo puede ser una configuración incorrecta de algunos objetos de directiva de grupo, en los que, según esta directiva, el producto antiguo debería seguir instalado en el sistema y no se detecta el proceso de actualización de la aplicación.
Solución

Comando:

C:\Users\Owner\Desktop\InstFix_nt64.exe -fix MRL -b

InstFix enumera todos los productos de seguridad ESET con un código de actualización MSI específico del Registro del instalador de Windows e intenta determinar la versión del instalador del producto actual. Las entradas de registro que no coinciden con la versión instalada se eliminan de las siguientes ubicaciones:

  • HKCR\Installer\UpgradeCodes
  • HKCR\Installer\Productos

Cuando se utiliza el modificador -b con este comando, cada entrada que se eliminará se guarda en un archivo REG independiente.


Falta el Registro MSI

Problema

Un intento de actualizar un producto ESET a la última versión falla al detener el servicio ESET (ekrn). El registro de instalación contiene secciones RunEngine que hacen referencia únicamente al paquete MSI que está instalado actualmente.

Causa
  • A Windows Installer le faltan entradas de registro para la aplicación instalada actualmente. Durante una actualización, el paquete MSI antiguo debe ser llamado en una sección RunEngine separada con su GUID listado como el nombre del producto. Tras desinstalar correctamente el paquete MSI antiguo, se inicia una nueva sección RunEngine y comienza la instalación principal de la última versión. Se desconoce la razón principal por la que faltan las entradas del Registro.
Solución

Comando:

C:\Users\Owner\Desktop\InstFix_nt64.exe -fix MMR

InstFix comprueba si el problema está presente e intenta restaurar todas las claves y valores obligatorios conocidos del Registro del Instalador de Windows.

  1. ¡Copie manualmente el paquete MSI original (mismo producto, versión, plataforma e idioma) del producto actualmente instalado en el directorio oculto del sistema %SystemRoot%\Installer!
  2. InstFix recopilará toda la información necesaria sobre el producto actualmente instalado y buscará el paquete MSI original en la caché MSI de Windows Installer. Si se encuentra el paquete MSI, se restaura una lista de claves y valores obligatorios del registro en las siguientes ubicaciones:

    • HKCR\Installer\UpgradeCodes
    • HKCR\Installer\Productos
    • HKLMSOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products

Índice del servicio de búsqueda

Problema

La instalación de un producto ESET falla en CA EpfwInst!FinalizeInstall en EpfwWfpRegisterCallouts con el código de error ERROR_RM_NOT_ACTIVE (0x1a91 = 6801).

Causa
  • Algunos archivos del sistema relacionados con el servicio Windows Search están dañados o se han dejado en un estado incoherente. Uno de los motivos puede ser que se haya realizado una Restauración del sistema.
Solución

Comando:

C:\Users\Owner\Desktop\InstFix_nt64.exe -fix SSI

InstFix elimina todos los archivos *.blf y *.regtrans-ms en las siguientes ubicaciones:

  • %RootSistema%\system32\config\TxR
  • %RootSistema%\system32\SMI\Store\Machine

InstFix intenta detener el servicio de búsqueda de Windows si se está ejecutando. Se aplica la corrección principal y el servicio se inicia de nuevo. Si no se consigue, puede ser necesario reiniciar el sistema.

Mayor carga de la CPU y del disco duro

Puede esperar una mayor carga de la CPU y del disco duro mientras se reconstruye el índice de búsqueda.


Tipos de valores del registro

Problema

La instalación de un producto de ESET Security falla en CA InstSupp!InstallDriverPackages for EDEVMON en SetupInstallFromInfSection con el código de error 13.

El registro APP de la API de instalación informa "[SetupInstallFromInfSection - DefaultInstall]" relacionado con el tiempo de error y EDEVMON ("inf: AddReg=EDEVMON") el problema "!!! inf: Error al establecer el valor de registro HKLM...".

Causa
  • Algunas aplicaciones de terceros escriben valores en el Registro utilizando el tipo de Registro incorrecto declarado en la documentación del Registro de Windows. Esto provoca fallos en la instalación del siguiente controlador porque Windows espera leer un tipo de Registro diferente.
Solución

Comando:

C:\Usuarios\Propietario\Escritorio\InstFix_nt64.exe -fix RVT -b

InstFix itera sobre una lista de valores de registro conocidos y comprueba sus tipos. Si un tipo no coincide con el tipo esperado, InstFix convierte el valor adecuadamente y lo almacena como el tipo de registro correcto y esperado.

Actualmente, la lista sólo contiene valores de registro EDEVMON ubicados en la clave de registro HKLM\System\CurrentControlSet\Control\Class. Cada valor del registro que necesite ser convertido será primero respaldado en un archivo REG separado cuando se utilice el modificador -b.

El software de terceros puede dejar de funcionar correctamente

El software de terceros que establece valores de registro utilizando tipos de registro incorrectos y luego intenta leer los valores fijados puede dejar de funcionar correctamente. Este problema debe notificarse como error de software al proveedor de la aplicación de terceros.


MaxNumFilters

Problema

La instalación de un producto ESET Security falla en CA InstSupp!InstallDriverPackages para EPFWLWF en HrInstallComponent con el código de error NETCFG_E_MAX_FILTER_LIMIT (0x8004a029).

Causa

Windows tiene una restricción para el número máximo de controladores de filtro de red que se pueden cargar a la vez. Si se alcanza el valor máximo, la siguiente instalación del controlador de filtro fallará. Cada versión de Windows tiene este valor máximo codificado y también definido en el Registro. El valor del Registro suele ser mucho menor que el valor codificado. Si el valor del Registro no está definido, se utilizará el valor codificado.

Ubicación

HKLM\SYSTEM\CurrentControlSet\Control\Network\MaxNumFilters:dword

Solución

Comando:

C:\Usuarios\Propietario\Escritorio\InstFix_nt64.exe -fix MNF

InstFix elimina el valor de registro MaxNumFilters que permite a Windows utilizar el valor interno hardcoded.


PSL Fix(Reparación de las sobras del servicio protegido)

Problema

Se intenta instalar un producto ESET Security tras una instalación fallida anterior.

El registro de instalación contiene: "Producto: ESET Security - Error 1923. No se pudo instalar el servicio 'ESET Service' (ekrn). Compruebe que dispone de privilegios suficientes para instalar servicios del sistema."

Causa
  • El Servicio ESET permanece protegido aunque no esté presente.
Solución

Comando:

C:\Usuarios\Propietario\Escritorio\instfix_nt64.exe -fix PSL -b
InstFix elimina la clave de Registro HKLM\System\CurrentControlSet\Services\ekrn\LaunchProtected si el servicio parece no estar instalado y no existe en el disco duro. Aún no se conocen efectos secundarios.

Arreglo de SIL (Arreglo de los restos de la instalación del servicio)

Problema

Se produce un error al intentar instalar un producto de ESET Security tras una instalación cancelada o revertida previamente.

El registro de instalación contiene: "Producto: ESET Security - Error 1923. No se pudo instalar el servicio 'ESET Service' (ekrn). Compruebe que dispone de privilegios suficientes para instalar servicios del sistema".

Causa
  • El Servicio ESET puede permanecer parcialmente registrado después de cancelar la instalación o cuando se produce una reversión.
Solución

Comando:

C:\Usuarios\Propietario\Escritorio\instfix_nt64.exe -fix SIL -b
InstFix elimina completamente la clave de Registro HKLM\System\CurrentControlSet\Services\ekrn si el servicio parece no estar instalado y no existe en el disco duro. Aún no se conocen efectos secundarios.

Corrección PIT (Corrección del tiempo de instalación del producto)

Problema

Si se utiliza ESET Remote Administrator (ERA) para realizar una instalación push de un producto Endpoint, a veces puede aparecer una fecha de instalación incorrecta en ERA.

Causa
  • Aún se desconoce la razón exacta de este comportamiento.
Solución

Comando:

C:\Users\Owner\Desktop\instfix_nt64.exe -fix PIT -b

InstFix recupera la fecha de instalación correcta del producto ESET Security del Registro del Instalador de Windows. A continuación, el valor PackageTag, que se encuentra dentro de la clave ESET Info, se codifica con la fecha correcta.

Toda la clave de registro ESET Info se respaldará primero en un archivo REG separado cuando se utilice el modificador -b.

Nota: Self-Defense prohíbe el acceso de escritura a la clave de información de ESET. ¡Para realizar esta corrección, Self-Defense debe desactivarse temporalmente mediante la configuración avanzada del producto o ERA! Aún no se conocen efectos secundarios.