[KB3544] ESET Installation Fixer

BEMÆRK:

Denne side er blevet oversat af en computer. Klik på engelsk under Sprog på denne side for at få vist den originale tekst. Hvis du finder noget uklart, bedes du kontakte din lokale support.

Problemstilling

Løsning

Hvad er en ESET Installation Fixer?

ESET Installation Fixer (InstaFix, install fix) er et teknisk supportværktøj til ESET-produkter. ESET Installation Fixer er designet til at løse flere problemer, der kan opstå med tjenester under installation af ESET-software.

Kun ESET home-, endpoint- og serverprodukter

ESET Installation Fixer-værktøjet kan kun bruges til ESET home-, endpoint- og serverprodukter. Det kan ikke bruges til Management Agents.

Før du bruger ESET Installation Fixer
  • Kør kun programmet efter råd fra ESET's tekniske support.
  • Programmet skal køres fra en administrativ konto. Installation Fixer-kommandoer skal udføres ved hjælp af en kommandoprompt med forhøjede fulde administratorrettigheder.
  • ESET Installation Fixer fungerer ikke i fejlsikret tilstand.
  • Når du arbejder på et 64-bit operativsystem, skal du bruge en 64-bit version af ESET Installation Fixer.
  • ESET Installation Fixer er beregnet til brug på Windows XP SP3 og senere versioner af Windows.

Denne aktuelle version understøtter følgende rettelser:


Hvordan bruger jeg ESET Installation Fixer?

  1. Klik på det relevante link nedenfor for at downloade ESET Installation Fixer til dit operativsystem (Klik for trin til at afgøre, om dit operativsystem er 32-bit eller 64-bit):
  1. Når værktøjet er downloadet, skal du køre ESET Installation Fixer fra en administrativ kommandoprompt ved hjælp af en af de kommandoer, der er beskrevet nedenfor. Alle kommandoer skal tilføjes efter den mappe, hvor Installation Fixer er placeret, f.eks:

    C:\Users\Owner\Desktop\InstFix_nt64.exe -fix MRL

    Brugere med 32-bit-versionen

    Brugere med 32-bit versionen af Installation Fixer vil skrive "InstFix_nt32.exe" i stedet for "InstFix_nt64.exe"


Rester af MSI-registreringsdatabasen

Problem

Et forsøg på at opgradere et ESET-produkt til den nyeste version mislykkes. Installationsloggen rapporterer fejlen "Fejl 2753: Filen 'shellExt.dll' er ikke markeret til installation."

Årsag
  • Opgraderingsprocessen bliver afbrudt af en ny installation af et tidligere produkt, som allerede er blevet opgraderet. Det sker lige efter, at den del af RunEngine, der er ansvarlig for at fjerne det produkt, der er ved at blive opgraderet, er afsluttet.
  • Tjenesten Group Policy Application Management (AppMgmt) mistænkes for at køre installationen af den manglende software. Årsagen til dette kan være en fejlkonfiguration af nogle gruppepolitikobjekter, hvor det gamle produkt i henhold til denne politik stadig skal være installeret på systemet, og applikationsopgraderingsprocessen ikke registreres.
Løsning

Kommando:

C:\Users\Owner\Desktop\InstFix_nt64.exe -fix MRL -b

InstFix opregner alle ESET-sikkerhedsprodukter med en specifik MSI-opgraderingskode fra Windows Installer-registreringsdatabasen og forsøger at bestemme installationsversionen af det aktuelle produkt. Registreringsposter, der ikke matcher den installerede version, slettes fra følgende steder:

  • HKCR\Installer\UpgradeCodes
  • HKCR\Installer\Produkter

Når du bruger -b-switchen med denne kommando, sikkerhedskopieres hver post, der slettes, til en separat REG-fil.


Manglende MSI-registreringsdatabase

Problem

Et forsøg på at opgradere et ESET-produkt til den nyeste version mislykkes, når ESET-tjenesten (ekrn) stoppes. Installationsloggen indeholder RunEngine-sektioner, der kun refererer til den MSI-pakke, der er installeret i øjeblikket.

Årsag
  • Windows Installer mangler poster i registreringsdatabasen for den aktuelt installerede applikation. Under en opgradering skal den gamle MSI-pakke kaldes i en separat RunEngine-sektion med dens GUID angivet som produktnavn. Efter en vellykket afinstallation af den gamle MSI-pakke starter en ny RunEngine-sektion, og hovedinstallationen af den nyeste version begynder. Hovedårsagen til, at poster i registreringsdatabasen mangler, er ukendt.
Løsning

Kommando:

C:\Users\Owner\Desktop\InstFix_nt64.exe -fix MMR

InstFix kontrollerer, om problemet er til stede, og forsøger derefter at gendanne alle kendte obligatoriske Windows Installer-registreringsnøgler og -værdier.

  1. Kopier manuelt den originale MSI-pakke (samme produkt, version, platform og sprog) for det aktuelt installerede produkt til den skjulte systemmappe %SystemRoot%\Installer!
  2. InstFix indsamler alle nødvendige oplysninger om det aktuelt installerede produkt og søger efter den originale MSI-pakke i Windows Installer MSI Cache. Hvis MSI-pakken findes, gendannes en liste over obligatoriske registreringsdatabasenøgler og -værdier på følgende steder:

    • HKCR\Installer\UpgradeCodes
    • HKCR\Installer\Produkter
    • HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products

Search Service Index

Problem

Installation af et ESET-produkt mislykkes i CA EpfwInst!FinalizeInstallEpfwWfpRegisterCallouts med fejlkoden ERROR_RM_NOT_ACTIVE (0x1a91 = 6801).

Årsag
  • Nogle systemfiler, der er relateret til Windows Search-tjenesten, er beskadiget eller efterladt i en inkonsistent tilstand. En af grundene til dette kan være, at der blev udført en systemgendannelse.
Løsning

Kommandoer:

C:\Users\Owner\Desktop\InstFix_nt64.exe -fix SSI

InstFix sletter alle *.blf- og *.regtrans-ms-filer på følgende steder:

  • %SystemRoot%\system32\config\TxR
  • %SystemRoot%\system32\SMI\Store\Machine

InstFix forsøger at stoppe Windows Search Service, hvis den kører. Hovedrettelsen anvendes, og tjenesten startes igen. En genstart kan stadig være nødvendig, hvis det ikke lykkes.

Højere CPU- og HDD-belastning

Du kan forvente højere CPU- og HDD-belastning, mens du genopbygger søgeindekset.


Typer af værdier i registreringsdatabasen

Problem

Installationen af et ESET Security-produkt mislykkes i CA InstSupp!InstallDriverPackages for EDEVMONSetupInstallFromInfSection med fejlkode 13.

Setup API APP-loggen rapporterer "[SetupInstallFromInfSection - DefaultInstall]" relateret til fejltidspunktet og EDEVMON ("inf: AddReg=EDEVMON " ) problemet "!!! inf: Fejl ved indstilling af registreringsdatabaseværdien HKLM...".

Årsag
  • Nogle tredjepartsprogrammer skriver værdier til registreringsdatabasen ved hjælp af den forkerte registreringsdatabasetype, som er angivet i dokumentationen til Windows-registreringsdatabasen. Det medfører fejl i driverinstallationen, når den næste driver installeres, fordi Windows forventer at læse en anden type i registreringsdatabasen.
Løsning

Kommando:

C:\Users\Owner\Desktop\InstFix_nt64.exe -fix RVT -b

InstFix gennemgår en liste over kendte værdier i registreringsdatabasen og kontrollerer deres typer. Hvis en type ikke matcher den forventede type, konverterer InstFix værdien korrekt og gemmer den som den korrekte og forventede type i registreringsdatabasen.

Listen indeholder i øjeblikket kun EDEVMON-registreringsværdier placeret under registreringsdatabasenøglen HKLM\System\CurrentControlSet\Control\Class. Hver registreringsdatabaseværdi, der skal konverteres, vil først blive sikkerhedskopieret til en separat REG-fil, når du bruger -b-switchen.

Tredjepartssoftware holder måske op med at fungere korrekt

Tredjepartssoftware, der indstiller registreringsdatabaseværdier ved hjælp af de forkerte registreringsdatabase-typer og derefter forsøger at læse de faste værdier, kan holde op med at fungere korrekt. Dette problem skal rapporteres som en softwarefejl til leverandøren af tredjepartsprogrammet.


MaxNumFiltre

Problem

Installationen af et ESET Security-produkt mislykkes i CA InstSupp!InstallDriverPackages for EPFWLWFHrInstallComponent med fejlkoden NETCFG_E_MAX_FILTER_LIMIT (0x8004a029).

Årsag

Windows har en begrænsning for det maksimale antal netværksfilterdrivere, der kan indlæses ad gangen. Hvis den maksimale værdi er nået, vil den næste installation af filterdriveren mislykkes. Hver version af Windows har denne maksimale værdi kodet og også defineret i registreringsdatabasen. Værdien i registreringsdatabasen er typisk sat til en meget mindre værdi end den hardcodede. Hvis værdien i registreringsdatabasen ikke er defineret, bruges den hardkodede værdi.

Placering

HKLM\SYSTEM\CurrentControlSet\Control\Network\MaxNumFilters:dword

Løsning

Kommando:

C:\Users\Owner\Desktop\InstFix_nt64.exe -fix MNF

InstFix sletter MaxNumFilters-registreringsværdien, hvilket gør det muligt for Windows at bruge den interne hardcodede værdi.


PSL-rettelse(rettelseaf rester af beskyttet tjeneste)

Problem

Et forsøg på at installere et ESET Security-produkt efter en tidligere mislykket installation.

Installationsloggen indeholder: "Produkt: ESET Security - Fejl 1923. Tjenesten 'ESET Service' (ekrn) kunne ikke installeres. Kontrollér, at du har tilstrækkelige rettigheder til at installere systemtjenester."

Årsag
  • ESET-tjenesten forbliver beskyttet, selv om den ikke er til stede.
Løsning

Kommando til:

C:\Users\Owner\Desktop\instfix_nt64.exe -fix PSL -b
InstFix sletter registreringsnøglen HKLM\System\CurrentControlSet\Services\ekrn\LaunchProtected, hvis tjenesten ikke ser ud til at være installeret og ikke findes på harddisken. Der er endnu ingen kendte bivirkninger.

SIL-rettelse (rettelse af rester af serviceinstallation)

Problem

Et forsøg på at installere et ESET Security-produkt efter en tidligere annulleret eller tilbagerullet installation mislykkes.

Installationsloggen indeholder: "Produkt: ESET Security - Fejl 1923. Tjenesten 'ESET Service' (ekrn) kunne ikke installeres. Kontrollér, at du har tilstrækkelige rettigheder til at installere systemtjenester."

Årsag
  • ESET-tjenesten kan forblive delvist registreret, efter at installationen er annulleret, eller når der sker en tilbageførsel.
Løsning

Kommando:

C:\Users\Owner\Desktop\instfix_nt64.exe -fix SIL -b
InstFix sletter registreringsnøglen HKLM\System\CurrentControlSet\Services\ekrn helt, hvis tjenesten ikke synes at være installeret og ikke findes på harddisken. Der er endnu ingen kendte bivirkninger.

PIT-rettelse (rettelse af produktinstallationstid)

Problem

Brug af ESET Remote Administrator (ERA) til at foretage en push-installation af et Endpoint-produkt kan nogle gange resultere i, at der vises en forkert installationsdato i ERA.

Årsag
  • Den nøjagtige årsag til denne adfærd er endnu ukendt.
Løsning

Kommando:

C:\Users\Owner\Desktop\instfix_nt64.exe -fix PIT -b

InstFix henter den korrekte installationsdato for ESET Security-produktet fra Windows Installer-registreringsdatabasen. Derefter kodes PackageTag-værdien, som findes i ESET Info-nøglen, med den korrekte dato.

Hele ESET Info-registreringsnøglen vil først blive sikkerhedskopieret til en separat REG-fil, når man bruger -b-switchen.

Bemærk: Self-Defense forbyder skriveadgang til ESET Info Key. For at udføre denne rettelse skal Self-Defense deaktiveres midlertidigt ved hjælp af produktets avancerede indstillinger eller ERA! Der er endnu ingen kendte bivirkninger.