[KB3544] Correcteur d'installation ESET

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Problème

Solution

Qu'est-ce qu'un correcteur d'installation ESET ?

Le correcteur d'installation ESET (InstaFix, install fix) est un outil d'assistance technique pour les produits ESET. Le correcteur d'installation ESET est conçu pour résoudre plusieurs problèmes qui peuvent survenir avec les services lors de l'installation du logiciel ESET.

Produits ESET pour la maison, les endpoint et les serveurs uniquement

L'outil ESET Installation Fixer ne peut être utilisé que pour les produits ESET Home, Endpoint et Server. Il ne peut pas être utilisé pour les agents de gestion.

Avant d'utiliser ESET Installation Fixer
  • Exécutez le programme uniquement sur les conseils de l'assistance technique d'ESET.
  • Le programme doit être exécuté à partir d'un compte administratif. Les commandes du correcteur d'installation doivent être exécutées à l'aide d'une invite de commande avec des privilèges d'administrateur complet.
  • Le correcteur d'installation ESET ne fonctionne pas en mode sans échec.
  • Lorsque vous travaillez sur un système d'exploitation 64 bits, vous devez utiliser une version 64 bits du réparateur d'installation ESET.
  • ESET Installation Fixer est destiné à être utilisé sur Windows XP SP3 et les versions ultérieures de Windows.

Cette version actuelle prend en charge les correctifs suivants :


Comment utiliser ESET Installation Fixer ?

  1. Cliquez sur le lien approprié ci-dessous pour télécharger le correcteur d'installation ESET pour votre système d'exploitation (Cliquez ici pour connaître les étapes à suivre afin de déterminer si votre système d exploitation est en 32 bits ou en 64 bits.) :
  1. Une fois le téléchargement de l'outil terminé, exécutez ESET Installation Fixer à partir d'une invite de commande administrative à l'aide de l'une des commandes décrites ci-dessous. Toutes les commandes doivent être ajoutées après le répertoire où se trouve le correcteur d'installation, par exemple :

    C:\NUsers\NPropriétaire\NBureau\NInstFix_nt64.exe -fix MRL

    Utilisateurs de la version 32 bits

    Les utilisateurs de la version 32 bits du fixateur d'installation taperont "InstFix_nt32.exe" au lieu de "InstFix_nt64.exe"


Restes de registre MSI

Problème

Une tentative de mise à niveau d'un produit ESET vers la dernière version échoue. Le journal d'installation signale l'erreur "Error 2753 : The File 'shellExt.dll' is not marked for installation" (Erreur 2753 : le fichier 'shellExt.dll' n'est pas marqué pour l'installation)

Cause
  • Le processus de mise à niveau est interrompu par une nouvelle installation d'un produit antérieur qui a déjà été mis à niveau dans le passé. Cela se produit juste après que la section RunEngine responsable de la suppression du produit en cours de mise à niveau se soit terminée avec succès.
  • Le service de gestion des applications de stratégie de groupe (AppMgmt) est soupçonné d'exécuter l'installation du logiciel manquant. La raison peut être une mauvaise configuration de certains objets de stratégie de groupe, où selon cette stratégie l'ancien produit devrait toujours être installé sur le système, et le processus de mise à niveau de l'application n'est pas détecté.
Solution

Commande :

C:\NUsers\NPropriétaire\NBureau\NInstFix_nt64.exe -fix MRL -b

InstFix énumère tous les produits de sécurité ESET avec un code de mise à niveau MSI spécifique à partir du registre de l'installateur Windows et tente de déterminer la version d'installation du produit actuel. Les entrées de registre qui ne correspondent pas à la version installée sont supprimées des emplacements suivants :

  • HKCR\Installer\UpgradeCodes
  • HKCR\Installer\Produits

Lorsque vous utilisez le commutateur -b avec cette commande, chaque entrée qui sera supprimée est sauvegardée dans un fichier REG distinct.


Registre MSI manquant

Problème

Une tentative de mise à niveau d'un produit ESET vers la dernière version échoue lors de l'arrêt du service ESET (ekrn). Le journal d'installation contient des sections RunEngine qui ne font référence qu'au package MSI actuellement installé.

Cause de l'échec
  • Il manque à Windows Installer des entrées de registre pour l'application actuellement installée. Lors d'une mise à niveau, l'ancien package MSI doit être appelé dans une section RunEngine distincte, avec son GUID indiqué comme nom de produit. Après une désinstallation réussie de l'ancien paquetage MSI, une nouvelle section RunEngine démarre et l'installation principale de la dernière version commence. La raison principale pour laquelle les entrées de registre sont manquantes est inconnue.
Solution

Commande :

C:\NUsers\NPropriétaire\NDesktop\NInstFix_nt64.exe -fix MMR

InstFix vérifie si le problème est présent et tente ensuite de restaurer toutes les clés et valeurs obligatoires connues du registre de l'installateur Windows.

  1. Copiez manuellement le paquet MSI d'origine (même produit, même version, même plate-forme et même langue) du produit actuellement installé dans le répertoire système caché %SystemRoot%\Installer!
  2. InstFix rassemblera toutes les informations nécessaires sur le produit actuellement installé et recherchera le paquet MSI original dans le cache MSI de Windows Installer. Si le paquet MSI est trouvé, une liste de clés et de valeurs de registre obligatoires est restaurée dans les emplacements suivants :

    • HKCR\Installer\UpgradeCodes
    • HKCR\Installer\Produits
    • HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Produits

Index du service de recherche

Problème

L'installation d'un produit ESET échoue dans CA EpfwInst!FinalizeInstall sur EpfwWfpRegisterCallouts avec le code d'erreur ERROR_RM_NOT_ACTIVE (0x1a91 = 6801).

Cause de l'erreur
  • Certains fichiers système liés au service Windows Search sont corrompus ou laissés dans un état incohérent. Cela peut s'expliquer par le fait qu'une restauration du système a été effectuée.
Solution

Commande :

C:\NUsers\NPropriétaire\NBureau\NInstFix_nt64.exe -fix SSI

InstFix supprime tous les fichiers *.blf et *.regtrans-ms dans les emplacements suivants :

  • %SystemRoot%\system32\config\TxR
  • %SystemRoot%\system32\SMI\Store\Machine

InstFix tente d'arrêter le service de recherche Windows s'il est en cours d'exécution. Le correctif principal est appliqué et le service est redémarré. En cas d'échec, un redémarrage peut être nécessaire.

Augmentation de la charge du processeur et du disque dur

Vous pouvez vous attendre à une charge plus élevée du processeur et du disque dur lors de la reconstruction de l'index de recherche.


Types de valeurs de registre

Problème

L'installation d'un produit ESET Security échoue dans CA InstSupp!InstallDriverPackages for EDEVMON sur SetupInstallFromInfSection avec le code d'erreur 13.

Le journal APP de l'API d'installation signale "[SetupInstallFromInfSection - DefaultInstall]" en rapport avec l'heure de l'erreur et EDEVMON ("inf : AddReg=EDEVMON") le problème " !!! inf : Error setting registry value HKLM...".

Cause
  • Certaines applications tierces écrivent des valeurs dans le registre en utilisant le mauvais type de registre tel qu'il est déclaré dans la documentation du registre Windows. Cela provoque des échecs lors de l'installation du pilote suivant, car Windows s'attend à lire un type de registre différent.
Solution

Commande :

C:\NUsers\NPropriétaire\NBureau\NInstFix_nt64.exe -fix RVT -b

InstFix parcourt une liste de valeurs de registre connues et vérifie leurs types. Si un type ne correspond pas au type attendu, InstFix convertit la valeur de manière appropriée et la stocke en tant que type de registre correct et attendu.

La liste ne contient actuellement que les valeurs de registre EDEVMON situées sous la clé de registre HKLM\System\CurrentControlSet\Control\Class. Chaque valeur de registre qui doit être convertie sera d'abord sauvegardée dans un fichier REG séparé lors de l'utilisation de l'option -b.

Les logiciels tiers peuvent cesser de fonctionner correctement

Les logiciels tiers qui définissent des valeurs de registre en utilisant les mauvais types de registre et qui tentent ensuite de lire les valeurs fixées peuvent cesser de fonctionner correctement. Ce problème doit être signalé au fournisseur de l'application tierce en tant que bogue logiciel.


MaxNumFilters

Problème

L'installation d'un produit ESET Security échoue dans CA InstSupp!InstallDriverPackages for EPFWLWF on HrInstallComponent avec le code d'erreur NETCFG_E_MAX_FILTER_LIMIT (0x8004a029).

Cause de l'erreur

Windows impose une limite au nombre maximum de pilotes de filtre réseau pouvant être chargés simultanément. Si la valeur maximale est atteinte, l'installation du pilote de filtre suivant échoue. Cette valeur maximale est codée en dur dans chaque version de Windows et est également définie dans le registre. La valeur du registre est généralement fixée à une valeur beaucoup plus petite que la valeur codée en dur. Si la valeur du registre n'est pas définie, c'est la valeur codée en dur qui est utilisée.

Emplacement

HKLM\SYSTEM\CurrentControlSet\Control\Network\MaxNumFilters:dword

Solution

Commande :

C:\NUsers\NPropriétaire\NBureau\NInstFix_nt64.exe -fix MNF

InstFix supprime la valeur de registre MaxNumFilters, ce qui permet à Windows d'utiliser la valeur interne codée en dur.


PSL Fix(The Protected Service Leftovers fix)

Problème

Tentative d'installation d'un produit ESET Security après l'échec d'une installation précédente.

Le journal d'installation contient le message suivant "Produit : ESET Security - Erreur 1923. Le service 'ESET Service' (ekrn) n'a pas pu être installé. Vérifiez que vous disposez des privilèges suffisants pour installer les services système."

Cause
  • Le service ESET reste protégé même s'il n'est pas présent.
Solution

Commande :

C:\NUsers\NPropriétaire\NBureau\Ninstfix_nt64.exe -fix PSL -b
InstFix supprime la clé de registre HKLM\System\CurrentControlSet\Services\ekrn\LaunchProtected si le service ne semble pas être installé et n'existe pas sur le disque dur. Aucun effet secondaire n'est encore connu.

Correction SIL (Correction des restes d'installation du service)

Problème

Une tentative d'installation d'un produit de sécurité ESET après une installation précédemment annulée ou reportée échoue.

Le journal d'installation contient le message suivant "Produit : ESET Security - Erreur 1923. Le service 'ESET Service' (ekrn) n'a pas pu être installé. Vérifiez que vous disposez des privilèges suffisants pour installer les services système."

Cause
  • Le service ESET peut rester partiellement enregistré après l'annulation de l'installation ou lors d'un retour en arrière.
Solution

Commande :

C:\NUsers\NPropriétaire\NBureau\Ninstfix_nt64.exe -fix SIL -b
InstFix supprime complètement la clé de registre HKLM\System\CurrentControlSet\Services\rn si le service ne semble pas être installé et n'existe pas sur le disque dur. Aucun effet secondaire n'est encore connu.

Correction PIT (Correction du temps d'installation du produit)

Problème

L'utilisation de l'Administrateur à distance ESET (ERA) pour effectuer une installation en mode push d'un produit Endpoint peut parfois entraîner l'affichage d'une date d'installation incorrecte dans l'ERA.

Cause
  • La raison exacte de ce comportement est encore inconnue.
Solution

Commande :

C:\NUsers\NPropriétaire\NDesktop\Ninstfix_nt64.exe -fix PIT -b

InstFix récupère la date d'installation correcte du produit ESET Security dans le registre de l'installateur Windows. Ensuite, la valeur PackageTag, trouvée dans la clé ESET Info, est encodée avec la date correcte.

L'ensemble de la clé de registre ESET Info sera d'abord sauvegardé dans un fichier REG séparé lors de l'utilisation de l'option -b.

Remarque : Self-Defense interdit l'accès en écriture à la clé ESET Info. Pour effectuer cette correction, Self-Defense doit être temporairement désactivé en utilisant les paramètres avancés du produit ou ERA ! Aucun effet secondaire n'est encore connu.