[KB3544] ESET Installations-Fixer

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Lösung

Was ist ein ESET Installation Fixer?

ESET Installation Fixer (InstaFix, install fix) ist ein technisches Support-Tool für ESET Produkte. ESET Installation Fixer wurde entwickelt, um verschiedene Probleme zu beheben, die bei der Installation von ESET Software auftreten können.

Nur für ESET Heimanwender-, Endpoint- und Server-Produkte

Das ESET Installation Fixer-Tool kann nur für ESET Heimanwender-, Endpoint- und Server-Produkte verwendet werden. Es kann nicht für Management Agents verwendet werden.

Vor der Verwendung von ESET Installation Fixer
  • Führen Sie das Programm nur auf Anweisung des technischen Supports von ESET aus.
  • Das Programm muss von einem Administratorkonto aus ausgeführt werden. Die Befehle des Installation Fixer müssen über eine Eingabeaufforderung mit erweiterten Administratorrechten ausgeführt werden.
  • Der ESET Installation Fixer funktioniert nicht im abgesicherten Modus.
  • Wenn Sie mit einem 64-Bit-Betriebssystem arbeiten, müssen Sie eine 64-Bit-Version von ESET Installation Fixer verwenden.
  • ESET Installation Fixer ist für die Verwendung unter Windows XP SP3 und neueren Versionen von Windows vorgesehen.

Diese aktuelle Version unterstützt die folgenden Fixes:


Wie verwende ich ESET Installation Fixer?

  1. Klicken Sie auf den entsprechenden Link unten, um den ESET Installation Fixer für Ihr Betriebssystem herunterzuladen (Klicken Sie hier, um festzustellen, ob Ihr Betriebssystem 32-bit oder 64-bit ist):
  1. Nachdem das Tool heruntergeladen wurde, führen Sie den ESET Installation Fixer von einer administrativen Eingabeaufforderung aus mit einem der unten aufgeführten Befehle aus. Alle Befehle sollten nach dem Verzeichnis, in dem sich der Installation Fixer befindet, eingefügt werden, zum Beispiel:

    C:\Benutzer\Eigentümer\Desktop\InstFix_nt64.exe -fix MRL

    Benutzer mit der 32-Bit-Version

    Benutzer mit der 32-Bit-Version von Installation Fixer geben "InstFix_nt32.exe" statt "InstFix_nt64.exe" ein


MSI-Registry-Reste

Problem

Ein Versuch, ein ESET Produkt auf die neueste Version zu aktualisieren, schlägt fehl. Das Installationsprotokoll meldet den Fehler "Error 2753: The File 'shellExt.dll' is not marked for installation"

Ursache
  • Der Upgrade-Prozess wird durch eine neue Installation eines früheren Produkts unterbrochen, das bereits in der Vergangenheit aktualisiert wurde. Dies geschieht unmittelbar nach dem erfolgreichen Abschluss des RunEngine-Abschnitts, der für die Entfernung des aktuell zu aktualisierenden Produkts zuständig ist.
  • Der Gruppenrichtlinien-Anwendungsverwaltungsdienst (AppMgmt) wird verdächtigt, die Installation der fehlenden Software auszuführen. Der Grund dafür kann eine Fehlkonfiguration einiger Gruppenrichtlinienobjekte sein, bei denen gemäß dieser Richtlinie das alte Produkt noch auf dem System installiert sein sollte, und der Anwendungs-Upgrade-Prozess wird nicht erkannt.
Lösung

Befehl:

C:\Users\Eigentümer\Desktop\InstFix_nt64.exe -fix MRL -b

InstFix listet alle ESET Sicherheitsprodukte mit einem bestimmten MSI-Upgrade-Code aus der Windows Installer-Registrierung auf und versucht, die Installer-Version des aktuellen Produkts zu ermitteln. Registrierungseinträge, die nicht mit der installierten Version übereinstimmen, werden an den folgenden Stellen gelöscht:

  • HKCR\Installer\UpgradeCodes
  • HKCR\Installer\Produkte

Wenn Sie die Option -b mit diesem Befehl verwenden, wird jeder zu löschende Eintrag in einer separaten REG-Datei gesichert.


Fehlende MSI-Registry

Problem

Ein Versuch, ein ESET Produkt auf die neueste Version zu aktualisieren, schlägt fehl, wenn der ESET Dienst (ekrn) gestoppt wird. Das Installationsprotokoll enthält RunEngine-Abschnitte, die nur auf das MSI-Paket verweisen, das derzeit installiert ist.

Ursache
  • Dem Windows Installer fehlen Registrierungseinträge für die aktuell installierte Anwendung. Während eines Upgrades muss das alte MSI-Paket in einem separaten RunEngine-Abschnitt aufgerufen werden, dessen GUID als Produktname aufgeführt ist. Nach einer erfolgreichen Deinstallation des alten MSI-Pakets wird ein neuer RunEngine-Abschnitt gestartet, und die Hauptinstallation der neuesten Version beginnt. Der Hauptgrund für das Fehlen der Registry-Einträge ist unbekannt.
Lösung

Befehl:

C:\Users\Eigentümer\Desktop\InstFix_nt64.exe -fix MMR

InstFix prüft, ob das Problem vorhanden ist, und versucht dann, alle bekannten obligatorischen Registry-Schlüssel und -werte des Windows Installers wiederherzustellen.

  1. Kopieren Sie das originale MSI-Paket (gleiches Produkt, Version, Plattform und Sprache) des aktuell installierten Produkts manuell in das versteckte Systemverzeichnis %SystemRoot%\Installer!
  2. InstFix sammelt alle erforderlichen Informationen über das aktuell installierte Produkt und sucht das ursprüngliche MSI-Paket im MSI-Cache des Windows Installers. Wenn das MSI-Paket gefunden wird, wird eine Liste der obligatorischen Registry-Schlüssel und -werte an den folgenden Stellen wiederhergestellt:

    • HKCR\Installer\UpgradeCodes
    • HKCR\Installer\Produkte
    • HKLM\SOFTWARE\Microsoft\Windows\AktuelleVersion\Installer\Benutzerdaten\S-1-5-18\Produkte

Dienstindex durchsuchen

Problem

Die Installation eines ESET Produkts schlägt in CA EpfwInst!FinalizeInstall auf EpfwWfpRegisterCallouts mit Fehlercode ERROR_RM_NOT_ACTIVE (0x1a91 = 6801) fehl.

Ursache
  • Einige Systemdateien im Zusammenhang mit dem Windows-Suchdienst sind beschädigt oder befinden sich in einem inkonsistenten Zustand. Ein Grund dafür kann sein, dass eine Systemwiederherstellung durchgeführt wurde.
Lösung

Befehl:

C:\Users\Besitzer\Desktop\InstFix_nt64.exe -fix SSI

InstFix löscht alle *.blf- und *.regtrans-ms-Dateien an den folgenden Speicherorten:

  • %SystemRoot%\system32\config\TxR
  • %SystemRoot%\system32\SMI\Store\Machine

InstFix versucht, den Windows-Suchdienst zu stoppen, wenn er ausgeführt wird. Der Hauptfix wird angewendet, und der Dienst wird erneut gestartet. Ein Neustart kann auch dann erforderlich sein, wenn er nicht erfolgreich war.

Höhere CPU- und Festplattenauslastung

Während des Wiederaufbaus des Suchindexes ist mit einer höheren CPU- und Festplattenbelastung zu rechnen.


Typen von Registrierungswerten

Problem

Die Installation eines ESET Security-Produkts schlägt in CA InstSupp!InstallDriverPackages for EDEVMON auf SetupInstallFromInfSection mit Fehlercode 13 fehl.

Das Setup API APP-Protokoll meldet "[SetupInstallFromInfSection - DefaultInstall]" in Bezug auf die Fehlerzeit und EDEVMON ("inf: AddReg=EDEVMON") das Problem "!!! inf: Fehler beim Setzen des Registrierungswerts HKLM...".

Ursache
  • Einige Anwendungen von Drittanbietern schreiben Werte in die Registrierung und verwenden dabei den falschen Registrierungstyp, der in der Windows-Registrierungsdokumentation angegeben ist. Dies führt zu Fehlern bei der Treiberinstallation, wenn der nächste Treiber installiert wird, weil Windows erwartet, einen anderen Registrierungstyp zu lesen.
Lösung

Befehl:

C:\Users\Besitzer\Desktop\InstFix_nt64.exe -fix RVT -b

InstFix durchläuft eine Liste bekannter Registrierungswerte und prüft deren Typen. Wenn ein Typ nicht mit dem erwarteten Typ übereinstimmt, konvertiert InstFix den Wert entsprechend und speichert ihn als den korrekten und erwarteten Registrierungstyp.

Die Liste enthält derzeit nur EDEVMON-Registrierungswerte, die sich unter dem Registrierungsschlüssel HKLM\System\CurrentControlSet\Control\Class befinden . Jeder Registrierungswert, der konvertiert werden muss, wird zunächst in einer separaten REG-Datei gesichert, wenn Sie die Option -b verwenden.

Software von Drittanbietern funktioniert möglicherweise nicht mehr richtig

Software von Drittanbietern, die Registrierungswerte unter Verwendung der falschen Registrierungstypen festlegt und dann versucht, die festgelegten Werte zu lesen, funktioniert möglicherweise nicht mehr ordnungsgemäß. Dieses Problem muss als Softwarefehler an den Hersteller der Drittanwendung gemeldet werden.


MaxNumFilters

Problem

Die Installation eines ESET Security-Produkts schlägt in CA InstSupp!InstallDriverPackages für EPFWLWF auf HrInstallComponent mit dem Fehlercode NETCFG_E_MAX_FILTER_LIMIT (0x8004a029) fehl.

Ursache

Windows hat eine Beschränkung für die maximale Anzahl von Netzwerkfiltertreibern, die gleichzeitig geladen werden können. Wenn der Maximalwert erreicht ist, schlägt die nächste Filtertreiberinstallation fehl. In jeder Version von Windows ist dieser Maximalwert fest kodiert und auch in der Registrierung definiert. Der Wert in der Registry ist in der Regel auf einen viel kleineren Wert als den fest kodierten eingestellt. Wenn der Wert in der Registrierung nicht definiert ist, wird der fest kodierte Wert verwendet.

Speicherort

HKLM\SYSTEM\CurrentControlSet\Control\Network\MaxNumFilters:dword

Lösung

Befehl:

C:\Users\Besitzer\Desktop\InstFix_nt64.exe -fix MNF

InstFix löscht den MaxNumFilters-Registrierungswert, wodurch Windows den internen, fest kodierten Wert verwenden kann.


PSL Fix (Protected Service Reste-Fix)

Problem

Ein Versuch, ein ESET Security-Produkt nach einer zuvor fehlgeschlagenen Installation zu installieren.

Das Installationsprotokoll enthält: "Produkt: ESET Security - Fehler 1923. Der Dienst 'ESET Service' (ekrn) konnte nicht installiert werden. Stellen Sie sicher, dass Sie über ausreichende Berechtigungen zur Installation von Systemdiensten verfügen."

Ursache
  • Der ESET Dienst bleibt geschützt, auch wenn er nicht vorhanden ist.
Lösung

Befehl:

C:\Users\Besitzer\Desktop\instfix_nt64.exe -fix PSL -b
InstFix löscht den Registrierungsschlüssel HKLM\System\CurrentControlSet\Services\ekrn\LaunchProtected, wenn der Dienst nicht installiert zu sein scheint und nicht auf der Festplatte vorhanden ist. Es sind noch keine Nebenwirkungen bekannt.

SIL Fix (Fix für die Reste der Dienstinstallation)

Problem

Der Versuch, ein ESET Security-Produkt nach einer zuvor abgebrochenen oder rückgängig gemachten Installation zu installieren, schlägt fehl.

Das Installationsprotokoll enthält: "Produkt: ESET Security - Fehler 1923. Der Dienst 'ESET Service' (ekrn) konnte nicht installiert werden. Stellen Sie sicher, dass Sie über ausreichende Berechtigungen zur Installation von Systemdiensten verfügen."

Ursache
  • Der ESET-Dienst bleibt möglicherweise teilweise registriert, nachdem die Installation abgebrochen wurde oder wenn ein Rollback erfolgt.
Lösung

Befehl:

C:\Users\Owner\Desktop\instfix_nt64.exe -fix SIL -b
InstFix löscht den Registrierungsschlüssel HKLM\System\CurrentControlSet\Services\ekrn vollständig, wenn der Dienst nicht installiert zu sein scheint und nicht auf der Festplatte vorhanden ist. Es sind noch keine Nebenwirkungen bekannt.

PIT-Fix (Produktinstallationszeit-Fix)

Problem

Die Verwendung des ESET Remote Administrator (ERA) zur Durchführung einer Push-Installation eines Endpoint-Produkts kann manchmal dazu führen, dass im ERA ein falsches Installationsdatum angezeigt wird.

Ursache
  • Der genaue Grund für dieses Verhalten ist noch nicht bekannt.
Lösung

Befehl:

C:\Users\Eigentümer\Desktop\instfix_nt64.exe -fix PIT -b

InstFix ruft das korrekte Installationsdatum des ESET Security-Produkts aus der Windows Installer-Registrierung ab. Anschließend wird der PackageTag-Wert, der sich im ESET Info Key befindet, mit dem korrekten Datum kodiert.

Der gesamte ESET Info-Registrierungsschlüssel wird zunächst in einer separaten REG-Datei gesichert, wenn Sie den Schalter -b verwenden.

Hinweis: Self-Defense verbietet den Schreibzugriff auf den ESET Info Key. Um diesen Fix durchzuführen, muss Self-Defense vorübergehend über die erweiterten Einstellungen des Produkts oder ERA! deaktiviert werden Bisher sind keine Nebenwirkungen bekannt.