[KB3544] ESET Installations-Fixer

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Problem

Lösung

Was ist ESET Installation Fixer?

ESET Installation Fixer (auch bekannt als InstaFix oder Install Fix) ist ein technisches Support-Tool für ESET-Anwendungen. ESET Installation Fixer wurde entwickelt, um verschiedene Serviceprobleme zu beheben, die während der Installation von ESET-Software auftreten können.

Nur für ESET Home-, Endpoint- und Server-Anwendungen

ESET Installation Fixer kann nur für ESET Home-, Endpoint- und Server-Anwendungen verwendet werden. Er kann nicht für Management Agents verwendet werden.

Vor der Verwendung von ESET Installation Fixer
  • Führen Sie das Programm nur auf Anweisung des technischen Supports von ESET aus.
  • Das Programm muss von einem Administratorkonto aus ausgeführt werden. Die Befehle des Installation Fixer müssen über eine Eingabeaufforderung mit erweiterten Administratorrechten ausgeführt werden.
  • Der ESET Installation Fixer funktioniert nicht im abgesicherten Modus.
  • Wenn Sie mit einem 64-Bit-Betriebssystem arbeiten, müssen Sie eine 64-Bit-Version von ESET Installation Fixer verwenden.
  • ESET Installation Fixer ist für die Verwendung unter Windows XP SP3 und späteren Versionen von Windows vorgesehen.

Diese aktuelle Version unterstützt die folgenden Fixes:


Wie verwende ich ESET Installation Fixer?

  1. Klicken Sie auf einen der unten stehenden Links, um ESET Installation Fixer für Ihr Betriebssystem herunterzuladen. Falls erforderlich, überprüfen Sie, ob Ihr Betriebssystem 32-bit oder 64-bit ist.

  2. Führen Sie die Eingabeaufforderung als Administrator aus und führen Sie einen Befehl aus einem der folgenden Abschnitte aus, der Ihrem Problem entspricht. Der Befehl muss das Verzeichnis angeben, in dem sich der Installation Fixer befindet. Beispielbefehl:

    C:\Benutzer\Besitzer\Desktop\InstFix_nt64.exe -fix MRL

    Ersetzen Sie C:\Benutzer\Eigentümer\Desktop\InstFix_nt64.exe durch das tatsächliche Installations-Fixer-Verzeichnis und den Dateinamen. Wenn Sie die 32-Bit-Version verwenden, stellen Sie sicher, dass Sie InstFix_nt32.exe anstelle von InstFix_nt64.exe verwenden.


MSI-Registrierungsreste

Problem

Ein Versuch, eine ESET-Anwendung auf die neueste Version zu aktualisieren, schlägt fehl. Das Installationsprotokoll meldet den Fehler "Fehler 2753: Die Datei 'shellExt.dll' ist nicht für die Installation markiert."

Ursache

Der Upgrade-Prozess wird unterbrochen, wenn eine frühere Version der Anwendung automatisch wieder installiert wird, nachdem die aktuelle Version erfolgreich entfernt wurde. Dies geschieht unmittelbar nach der RunEngine-Phase, in der die vorhandene Anwendung entfernt wird.

Diese Neuinstallation wird wahrscheinlich vom Gruppenrichtlinien-Anwendungsverwaltungsdienst (AppMgmt) ausgelöst, weil eine Gruppenrichtlinienkonfiguration noch die Installation der älteren Anwendung erfordert. Da der Upgrade-Prozess diese richtliniengesteuerte Installation nicht erkennt, kann er nicht korrekt ablaufen.

Lösung

Befehl:

C:\Users\Owner\Desktop\InstFix_nt64.exe -fix MRL -b

InstFix listet alle ESET-Sicherheitsanwendungen mit einem bestimmten MSI-Upgrade-Code aus der Windows Installer-Registrierung auf und versucht, die Installer-Version der aktuellen Anwendung zu ermitteln. Registrierungseinträge, die nicht mit der installierten Version übereinstimmen, werden an den folgenden Stellen gelöscht:

  • HKCR\Installer\UpgradeCodes
  • HKCR\Installer\Produkte

Wenn Sie die Option -b mit diesem Befehl verwenden, wird jeder zu löschende Eintrag in einer separaten .reg-Datei gesichert.


Fehlende MSI-Registrierung

Problem

Ein Versuch, eine ESET-Anwendung auf die neueste Version zu aktualisieren, schlägt fehl, wenn der ESET-Dienst (ekrn) gestoppt wird. Das Installationsprotokoll enthält RunEngine-Abschnitte, die nur auf das aktuell installierte MSI-Paket verweisen.

Ursache

Dem Windows Installer fehlen Registrierungseinträge für die aktuell installierte Anwendung. Während eines Upgrades muss das alte MSI-Paket in einem separaten RunEngine-Abschnitt aufgerufen werden, in dem seine GUID als Anwendungsname aufgeführt ist. Nach einer erfolgreichen Deinstallation des alten MSI-Pakets wird ein neuer RunEngine-Abschnitt gestartet, und die Hauptinstallation der neuesten Version beginnt. Der Hauptgrund für das Fehlen der Registry-Einträge ist unbekannt.

Lösung

Befehl:

C:\Benutzer\Eigentümer\Desktop\InstFix_nt64.exe -fix MMR

InstFix prüft, ob das Problem vorliegt, und versucht dann, alle bekannten obligatorischen Windows Installer-Registrierungsschlüssel und -werte wiederherzustellen.

  1. Kopieren Sie das ursprüngliche MSI-Paket (gleiche Anwendung, Version, Plattform und Sprache) der aktuell installierten Anwendung manuell in das versteckte Systemverzeichnis %SystemRoot%\Installer!
  2. InstFix sammelt alle erforderlichen Informationen über die aktuell installierte Anwendung und sucht das ursprüngliche MSI-Paket im MSI-Cache des Windows Installers. Wenn das MSI-Paket gefunden wird, wird eine Liste der obligatorischen Registrierungsschlüssel und -werte an den folgenden Stellen wiederhergestellt:

    • HKCR\Installer\UpgradeCodes
    • HKCR\Installer\Produkte
    • HKLM\SOFTWARE\Microsoft\Windows\AktuelleVersion\Installer\Benutzerdaten\S-1-5-18\Produkte

Dienstindex durchsuchen

Problem

Die Installation einer ESET-Anwendung schlägt in CA EpfwInst!FinalizeInstall auf EpfwWfpRegisterCallouts mit Fehlercode ERROR_RM_NOT_ACTIVE (0x1a91 = 6801) fehl.

Ursache

Einige Systemdateien im Zusammenhang mit dem Windows-Suchdienst sind beschädigt oder befinden sich in einem inkonsistenten Zustand. Ein Grund dafür kann sein, dass eine Systemwiederherstellung durchgeführt wurde.

Lösung

Befehl:

C:\Benutzer\Besitzer\Desktop\InstFix_nt64.exe -fix SSI

InstFix löscht alle *.blf- und *.regtrans-ms-Dateien an den folgenden Speicherorten:

  • %SystemRoot%\system32\config\TxR
  • %SystemRoot%\system32\SMI\Store\Machine

InstFix versucht, den Windows-Suchdienst zu stoppen, wenn er ausgeführt wird. Der Hauptfix wird angewendet, und der Dienst wird erneut gestartet. Ein Neustart kann auch dann erforderlich sein, wenn er nicht erfolgreich war.

Höhere CPU- und Festplattenauslastung

Während des Wiederaufbaus des Suchindexes ist mit einer höheren CPU- und Festplattenbelastung zu rechnen.


Typen von Registrierungswerten

Problem

Die Installation einer ESET Security-Anwendung schlägt in CA InstSupp!InstallDriverPackages for EDEVMON auf SetupInstallFromInfSection mit Fehlercode 13 fehl.

Das Setup API APP-Protokoll meldet "[SetupInstallFromInfSection - DefaultInstall]" in Bezug auf die Fehlerzeit und EDEVMON ("inf: AddReg=EDEVMON") das Problem "!!! inf: Fehler beim Setzen des Registrierungswerts HKLM...".

Ursache

Einige Anwendungen von Drittanbietern schreiben Werte in die Registry mit dem falschen Registry-Typ, wie in der Windows Registry dokumentiert. Dies führt zu Fehlern bei der Treiberinstallation, wenn der nächste Treiber installiert wird, weil Windows erwartet, einen anderen Registrierungstyp zu lesen.

Lösung

Befehl:

C:\Benutzer\Besitzer\Desktop\InstFix_nt64.exe -fix RVT -b

InstFix durchläuft eine Liste bekannter Registrierungswerte und prüft deren Typen. Wenn ein Typ nicht mit dem erwarteten Typ übereinstimmt, konvertiert InstFix den Wert entsprechend und speichert ihn als den korrekten und erwarteten Registrierungstyp.

Die Liste enthält derzeit nur EDEVMON-Registrierungswerte, die sich unter dem Registrierungsschlüssel HKLM\System\CurrentControlSet\Control\Class befinden. Jeder Registrierungswert, der konvertiert werden muss, wird zunächst in einer separaten .reg-Datei gesichert, wenn Sie die Option -b verwenden.

Software von Drittanbietern funktioniert möglicherweise nicht mehr richtig

Software von Drittanbietern, die Registrierungswerte unter Verwendung der falschen Registrierungstypen festlegt und dann versucht, die festgelegten Werte zu lesen, funktioniert möglicherweise nicht mehr ordnungsgemäß. Dieses Problem muss als Softwarefehler an den Hersteller der Drittanwendung gemeldet werden.


MaxNumFilters

Problem

Die Installation einer ESET Security-Anwendung schlägt in CA InstSupp!InstallDriverPackages for EPFWLWF auf HrInstallComponent mit dem Fehlercode NETCFG_E_MAX_FILTER_LIMIT (0x8004a029) fehl.

Ursache

Windows hat eine Beschränkung für die maximale Anzahl von Netzwerkfiltertreibern, die gleichzeitig geladen werden können. Wenn der Maximalwert erreicht ist, schlägt die nächste Filtertreiberinstallation fehl. In jeder Version von Windows ist dieser Maximalwert fest kodiert und auch in der Registrierung definiert. Der Wert in der Registry ist in der Regel viel kleiner als der fest kodierte Wert. Wenn der Wert in der Registrierung nicht definiert ist, wird der fest kodierte Wert verwendet.

Speicherort

HKLM\SYSTEM\CurrentControlSet\Control\Network\MaxNumFilters:dword

Lösung

Befehl:

C:\Benutzer\Besitzer\Desktop\InstFix_nt64.exe -fix MNF

InstFix löscht den MaxNumFilters-Registrierungswert, so dass Windows den internen, fest codierten Wert verwenden kann.


PSL Fix (Der Fix für geschützte Dienstüberreste)

Problem

Versuch der Installation einer ESET Security-Anwendung nach einer zuvor fehlgeschlagenen Installation.

Das Installationsprotokoll enthält:"Produkt: ESET Security - Fehler 1923. Der Dienst 'ESET Service' (ekrn) konnte nicht installiert werden. Stellen Sie sicher, dass Sie über ausreichende Berechtigungen zur Installation von Systemdiensten verfügen."

Ursache

Der ESET-Dienst bleibt geschützt, auch wenn er nicht vorhanden ist.

Lösung

Befehl:

C:\Benutzer\Besitzer\Desktop\instfix_nt64.exe -fix PSL -b

InstFix löscht den Registrierungsschlüssel HKLM\System\CurrentControlSet\Services\ekrn\LaunchProtected, wenn der Dienst nicht installiert ist oder nicht auf der Festplatte existiert. Es sind noch keine Nebenwirkungen bekannt.


SIL Fix (Der Fix für die Reste der Dienstinstallation)

Problem

Der Versuch, eine ESET Security-Anwendung nach einer zuvor abgebrochenen oder rückgängig gemachten Installation zu installieren, schlägt fehl.

Das Installationsprotokoll enthält:"Produkt: ESET Security - Fehler 1923. Der Dienst 'ESET Service' (ekrn) konnte nicht installiert werden. Stellen Sie sicher, dass Sie über ausreichende Berechtigungen zur Installation von Systemdiensten verfügen."

Ursache

Der ESET-Dienst bleibt möglicherweise teilweise registriert, nachdem die Installation abgebrochen wurde oder ein Rollback erfolgt ist.

Lösung

Befehl:

C:\Benutzer\Besitzer\Desktop\instfix_nt64.exe -fix SIL -b

InstFix löscht den Registrierungsschlüssel HKLM\System\CurrentControlSet\Services\ekrn vollständig, wenn der Dienst nicht installiert ist oder nicht auf der Festplatte existiert. Es sind noch keine Nebenwirkungen bekannt.


PIT Fix (Der Produktinstallationszeit-Fix)

Problem

Die Verwendung der ESET PROTECT Web Console zur Durchführung einer Push-Installation einer Endpoint-Anwendung kann manchmal dazu führen, dass ein falsches Installationsdatum in der ESET PROTECT Web Console angezeigt wird.

Ursache

Der genaue Grund für dieses Verhalten ist noch nicht bekannt.

Lösung

Befehl:

C:\Benutzer\Besitzer\Desktop\instfix_nt64.exe -fix PIT -b

InstFix ruft das korrekte Installationsdatum der ESET Security-Anwendung aus der Windows Installer-Registrierung ab. Dann wird der PackageTag-Wert, der sich im ESET Info Key befindet, mit dem korrekten Datum kodiert.

Der gesamte ESET Info-Registrierungsschlüssel wird zunächst in einer separaten .reg-Datei gesichert, wenn die Option -b verwendet wird.

Self-Defense verbietet den Schreibzugriff auf den ESET Info Key. Um diesen Fix durchzuführen, muss Self-Defense vorübergehend über die erweiterten Einstellungen der Anwendung in der ESET PROTECT Web Console deaktiviert werden. Bisher sind keine Nebenwirkungen bekannt.