[KB7697] Generate a HAR log file requested by ESET Technical Support

Issue

Details


Click to expand

A HAR (HTTP Archive format) file stores the logs of a web browser's interaction with a website.

ESET Technical Support may request that you generate and submit a HAR log file when an issue occurs while visiting a website.


Solution

Some browsers may shorten responses

To limit the size of generated HAR log files, some browsers may shorten website responses to 1MB. To collect the complete response in your HAR log file, we recommend you generate a HAR log file in Firefox with the response limit disabled.

Protect your username and password

If you type your login credentials during the log collection, the credentials will be a part of the HAR file you generate. We recommend that you start the log collection after you log in. If the issue appears during login, we recommend you use a temporary password during the log collection and change your password when you create the HAR file.

Use a secure method to send the HAR file

We recommend you send the HAR file to ESET Technical Support by uploading the HAR file in a password-protected encrypted ZIP file on an FTP server and sending the password via email.

Generate HAR log file in Google Chrome

  1. Open Google Chrome, click the menu icon (three dots ⋮ ) at the top right corner and click New incognito window. In the new Incognito window of Google Chrome, navigate to the website where the issue occurs.

  2. Click the menu icon (three dots ⋮ ) in the top right corner and click More Tools → Developer Tools.

  3. Click the Network tab, select the check box next to Keep log, click the Clear ⊘ button to clear any existing logs and confirm the Record ◼ button is red. If it is gray, click the gray Record ◼ icon to start recording.

  4. From the Developer Tools panel, click the Settings ⚙ button.

  5. Click Preferences. Under Network, select the check box next to Allow to generate HAR with sensitive data. 

    This step is optional

    This step is optional and should only be performed at technical support's request.

  6. Recreate the issue in your web browser.

  7. After the issue is recreated, click the Record ◼ button to stop recording, click the download icon and select Export HAR (sanitized) or Export HAR (with sensitive data).

  8. Choose a file path, type a name for the file and click Save.

  9. Upload the HAR file to your support ticket.


Generate HAR log file in Firefox

  1. Open Firefox and disable the response limit:

    1. In the address bar, type about:config and press Enter.

    2. In the search bar, type or copy/paste devtools.netmonitor.responseBodyLimit.

    3. Click the Edit (pencil) icon, set the value to 0 and click the Check mark icon to confirm the change.

  2. Click the Menu ☰ button in the top right corner and click New private window. In the new private window of Firefox, navigate to the website where the issue occurs.

  3. Click the Menu ☰ button in the top right corner and click More Tools → Web Developer Tools.

  4. Click Network and click the Clear button to clear any existing logs.

  5. Click the Gear ⚙ button and click Persist Logs.

  6. Recreate the issue in your web browser. Firefox starts logging automatically.

  7. After the issue is recreated, click the Pause recording ◼ button to stop further recording. Click the Gear ⚙ button and click Save all as HAR.

  8. Select a file path, type a name for the file and click Save.

  9. Upload the HAR log file to your support ticket.


Generate HAR log file in Safari

  1. Open Safari and click File → New Private Window. In the private window, navigate to the website where the issue is occurring.

  2. In the menu bar, click Safari → Settings.

  3. In the dialog box, click Advanced and select the check box next to Show features for web developers.

  4. In the menu bar, click Develop and click Show Web Inspector.

  5. Click Network and click the other filters icon, then select Preserve Log to enable it. 

  6. Recreate the issue in your web browser.

  7. After the issue is recreated, click Export.

  8. Type a name for the file and click Save.

  9. Upload the HAR log file to your support ticket.