[KB7725] Upgrade MS SQL Server Express pomocí ESET PROTECT On-Prem

POZNÁMKA:

Tato stránka byla přeložena počítačem. Chcete-li zobrazit originální text, klikněte v části Jazyky na této stránce na Angličtina. Pokud vám něco není jasné, obraťte se na místní podporu.

Obsah

  • Upgrade instance MS SQL Server Express nainstalované s ESET PROTECT On-Prem

Podrobnosti

SQL Express je bezplatná verze SQL od společnosti Microsoft, která má určitá omezení. Na jednu instanci může připadat maximálně 1 GB paměti RAM, maximální velikost databáze je 10 GB a na jednom serveru může být maximálně 50 instancí. SQL Express je omezen na 1 socket nebo 4 jádra, takže pokud potřebujete výkonnější prostředí, můžete zvážit upgrade na vyšší edici SQL Serveru.

Následující postup upgradu je velmi podobný pro SQL Server Express 2008 R2 a novější verze. Pro upgrade je nutné dočasně zastavit službu ESET PROTECT On-Prem Server a vytvořit úplnou zálohu databáze pro případ, že by proces upgrade nebyl řádně dokončen. Informace o podporovaných verzích a možnostech upgradu edice naleznete v dokumentaci dodavatele produktu SQL Express.

Řešení

  1. Instalační program ESET PROTECT On-Prem Server verze 8.x All-in-one používá ve výchozím nastavení SQL Express 2019. Chcete-li zkontrolovat, kterou verzi serveru SQL Server používáte, zkontrolujte protokol chyb, který je ve výchozím nastavení umístěn na adrese C:\Program Files\Microsoft SQL Server\MSSQL.n\MSSQL\Log\ERRORLOG a na adrese ERRORLOG.n Verze MS SQL Serveru je uvedena v prvních řádcích protokolu.
Obrázek 1-1
  1. Zastavte službu ESET PROTECT On-Prem Server.
     
  2. Vytvoření úplné zálohy databáze. Doporučujeme zadat nový název zálohovací sady. Pokud nezadáte nový název sady záloh a stávající název již byl použit, bude nová záloha připojena ke stávajícímu souboru a vytvoří zbytečně velký soubor zálohy.
     
  3. V závislosti na typu média, které použijete pro upgrade, připojte instalační ISO serveru SQL Server nebo spusťte instalační balíček a spusťte proces instalace.
     
  4. V okně Centrum instalace SQL Serveru klikněte na Maintenance → Edition Upgrade a spusťte průvodce změnou edice SQL Serveru.
Obrázek 1-2

 

  1. V okně Upgrade the Edition zadejte produktový klíč a klikněte na Next.
Obrázek 1-3

 

  1. Pokud souhlasíte s licenčními podmínkami, zaškrtněte políčko vedle položky Souhlasím s licenčními podmínkami a kliknutím na tlačítko Další pokračujte v aktualizaci.
Obrázek 1-4

 

  1. Po úspěšném absolvování kontroly Pravidel aktualizace edice je třeba zadat instanci serveru SQL Server, kterou chcete aktualizovat. Z rozbalovacího menu vyberte požadovanou instanci SQL Serveru (ERASQL, pokud jste použili výchozí konfiguraci instalace ESET PROTECT On-Prem Server) a zkontrolujte seznam nainstalovaných instancí níže. Kliknutím na tlačítko Další pokračujte.
Obrázek 1-5

 

  1. Průvodce je nyní připraven k aktualizaci. Ověřte funkce, které budou změněny, a klikněte na Upgrade.
Obrázek 1-6

 

  1. Vaše edice serveru SQL Server je nyní aktualizována. Chcete-li zkontrolovat novou verzi v souhrnném protokolu, klikněte na hypertextový odkaz v okně průvodce nebo zopakujte krok 1 tohoto článku a zkontrolujte nejnovější soubor protokolu chyb.
Obrázek 1-7
  1. Spusťte ESET PROTECT On-Prem.