[KB7472] System extensions compatibility in macOS 10.15.4

Issue

  • You receive the notification: "Legacy System Extensions - Existing software on your system loaded a system extension signed by "ESET, spol. s.r.o.", which will be incompatible with a future version of macOS. Contact the developer for support."

Details

In macOS 10.16, kernel extensions in the current form will no longer be supported and will be replaced by system extensions.

MacOS 10.15.4 and later will display Legacy System Extensions dialog to inform users about upcoming changes.

Solution

Click OK to dismiss the notification. Currently, no action is needed. Your ESET product will continue to work unaffected.

We are working on a solution to support the new system extensions that will be available before the release of macOS 10.16.

Click here for more information from Apple about the notification.